17 августа 2022, 21:54:25

Новости:

ПРОГНОЗ ПОГОДЫ В МОСКВЕ

31 ДЕКАБРЯ
Днем: +3 С      Ночью: +1 С


1 ЯНВАРЯ
Днем: +1 С   Ночью: 0 С


2 ЯНВАРЯ
Днем: +2 С   Ночью:  +1 С



ПОГОДА СЕЙЧАС > > >
http://forum.vivatv.net.ru/index.php?topic=5490.0


Установка Omicom-S2 PCI в Fedora

Автор Konstantin, 17 октября 2012, 13:09:13

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

Konstantin

ethereal, спасибо за советы и ответы. Помогают в изучении. С каждым разом открываешь что то новое.
Надеюсь получится установить экспериментальные драйвера.
  • Мои антенны: Triax 88 см.
  • Мои ресиверы: Dreambox 800
  • Мои спутники: от Eutelsat-7C 7 East до Экспресс-АМ3 103 East

Konstantin

Теперь версия 5.6
[Konstantin@localhost Загрузки]$ ./dvbversion
LinuxTV API ver. 5.6


Установил экспериментальные драйвера для карты Omicom-S2 без патчей. :)
  • Мои антенны: Triax 88 см.
  • Мои ресиверы: Dreambox 800
  • Мои спутники: от Eutelsat-7C 7 East до Экспресс-АМ3 103 East

ethereal

Цитата: Konstantin от 22 октября 2012, 15:34:07
ethereal, спасибо за советы и ответы. Помогают в изучении. С каждым разом открываешь что то новое.
Надеюсь получится установить экспериментальные драйвера.

Не за что :)

Цитата: Konstantin от 23 октября 2012, 15:31:40
Теперь версия 5.6
[Konstantin@localhost Загрузки]$ ./dvbversion
LinuxTV API ver. 5.6


Установил экспериментальные драйвера для карты Omicom-S2 без патчей. :)

Карта работает с ними?
  • Мои антенны: Lans 1.2 + Supral 0.9 + Supral 0.6
  • Мои ресиверы: TBS 8920, TeVii S464, Prof 7301, MyGica T230
  • Мои спутники: 13E, 31.5 E, 40E (C), 75E, 80E (Ku)
Don't believe (((fake))) news!

Konstantin

Цитата: ethereal от 25 октября 2012, 22:19:38
Карта работает с ними?

Да, карта Omicom-S2 работает без проблем с экспериментальными драйверами. :)
  • Мои антенны: Triax 88 см.
  • Мои ресиверы: Dreambox 800
  • Мои спутники: от Eutelsat-7C 7 East до Экспресс-АМ3 103 East

ethereal

Цитата: Konstantin от 25 октября 2012, 22:23:28
Цитата: ethereal от 25 октября 2012, 22:19:38
Карта работает с ними?

Да, карта Omicom-S2 работает без проблем с экспериментальными драйверами. :)

Значит в следующей версии ядра она будет поддерживаться и не будет небходимости собирать драйвера вручную
  • Мои антенны: Lans 1.2 + Supral 0.9 + Supral 0.6
  • Мои ресиверы: TBS 8920, TeVii S464, Prof 7301, MyGica T230
  • Мои спутники: 13E, 31.5 E, 40E (C), 75E, 80E (Ku)
Don't believe (((fake))) news!

Konstantin

Недавно вводил команду
yum install kernel
и отображалась доступной для установки новая версия ядра (kernel) 3.6.2
Не стал пока ставить во избежании проблем.
Следующая версия, ты имел в виду 3.7 или 3.6.2?
  • Мои антенны: Triax 88 см.
  • Мои ресиверы: Dreambox 800
  • Мои спутники: от Eutelsat-7C 7 East до Экспресс-АМ3 103 East

ethereal

Цитата: Konstantin от 25 октября 2012, 22:35:31
Недавно вводил команду
yum install kernel
и отображалась доступной для установки новая версия ядра (kernel) 3.6.2
Не стал пока ставить во избежании проблем.
Следующая версия, ты имел в виду 3.7 или 3.6.2?

Не стоит устанавливать 3.6.2, там обнаружили ошибку, приводящую к порче файловой системы. Обычно драйвера добавляются при выходе новой версии, а в подверсиях исправляют ошибки, поэтому добавят в 3.7 или 3.8. 
  • Мои антенны: Lans 1.2 + Supral 0.9 + Supral 0.6
  • Мои ресиверы: TBS 8920, TeVii S464, Prof 7301, MyGica T230
  • Мои спутники: 13E, 31.5 E, 40E (C), 75E, 80E (Ku)
Don't believe (((fake))) news!

Konstantin

Интересно, когда выйдет Fedora 18 там будет ядро версии 3.7 или 3.8?
  • Мои антенны: Triax 88 см.
  • Мои ресиверы: Dreambox 800
  • Мои спутники: от Eutelsat-7C 7 East до Экспресс-АМ3 103 East

Konstantin

Прочитал сейчас оказывается проблемы не только с версией ядра 3.6.2, но и более новой 3.6.3,
а также некоторыми старыми.

Вот, что пишут:
------
Теодор Тцо (Theodore Ts'o) опубликовал в списке рассылки разработчиков ядра Linux патч с устранением серьёзной ошибки в реализации файловой системы Ext4, которая при определённых условиях может привести к повреждению данных. Проблема вызвана внесением изменения в процессе подготовки версии 3.6.2, затрагивающего инфраструктуру журналирования jbd2 (Journaling block device). Ошибка проявляется в версиях ядра Linux 3.6.2, 3.6.3, 3.4.14, 3.4.15 и 3.5.7. Исправление пока доступно только в виде патча.

Причину ошибки удалось выявить только после длительного анализа внесённых изменений, так как источник проблемы было трудно отследить из-за непредсказуемого характера проявления ошибки - проблема проявлялась только на системах в которых ФС начинается с нулевого блока, после двух перезагрузок с достаточно коротким интервалом.

В итоге было выяснено, что проблема приводит к некорректному состоянию журнала при размонтировании ФС вслед за монтированием, из-за того, что лог изменений не успевает до конца записаться на диск. Если имело место единичное проявление проблемы, то драйвер Ext4 мог произвести восстановление журнала. Но если ситуация повторялась несколько раз подряд, то данные новой сессии монтирования успевали записаться до того как были записаны данные прошлой сессии, что приводило к некорректному состоянию данных в ФС.
--------

А когда будет доступно исправление не в виде патча? Как об этом узнать?
  • Мои антенны: Triax 88 см.
  • Мои ресиверы: Dreambox 800
  • Мои спутники: от Eutelsat-7C 7 East до Экспресс-АМ3 103 East

ethereal

Цитата: Konstantin от 25 октября 2012, 22:44:15
Интересно, когда выйдет Fedora 18 там будет ядро версии 3.7 или 3.8?

Скорее всего, 3.7.0, потому что уже сейчас собрали версию из git-репозитория (официально версия 3.7 еще не выпущена).

ЦитироватьА когда будет доступно исправление не в виде патча? Как об этом узнать?

Когда выйдет новая подверсия или версия ядра, патч будет включен в нее. Сейчас уже есть тестовая версия 3.7-rc2, думаю в ней ошибка исправлена.
  • Мои антенны: Lans 1.2 + Supral 0.9 + Supral 0.6
  • Мои ресиверы: TBS 8920, TeVii S464, Prof 7301, MyGica T230
  • Мои спутники: 13E, 31.5 E, 40E (C), 75E, 80E (Ku)
Don't believe (((fake))) news!